4

I came to meta and found that this post is featured 7 hours ago but I still can't see that post on main site (Attached image). I am really interested in weekly tag questions, but I would have missed it if I would not have come on meta and checked that out.

Does it take time to make the featured meta posts visible on main site or is there some bug that has just popped up?

Image 1

  • I was surprised that it doesn't seem to be alternating. I thought if more than one question had that tag it would switch off. But it seems to just do the first one. – Cyn Apr 3 at 4:49
  • It is working fine for me. Has this already been fixed? – linksassin Apr 3 at 6:20
  • 2
    As a general rule I'd say yes, it's because of caching. But over six hours is a rather long time for caching something that shouldn't be too expensive to regenerate... – a CVn Apr 3 at 6:34
  • 1
    meta.stackexchange.com/a/236689/157730 says that at least back in 2014, the cache was updated once per hour. – a CVn Apr 3 at 7:08
  • @linksassin Nop it's still not updated in my end – Karan Desai Apr 3 at 8:03
  • Finally now I can see the featured post on main site - it's bit late – Karan Desai Apr 3 at 12:45
  • 3
    There's a really long and erratic delay on featured posts making it to the Community Bulletin; I have no idea why. Sometimes it's an hour; sometimes it's half a day. Fortunately, the kinds of things we want to feature usually don't require immediate attention. – Monica Cellio Apr 3 at 15:27
  • 2
    The sidebar is supposed to refresh every hour but can serve cached data for up to 24 hours after that if it fails to update the data. It shouldn't stay stale that long but there may be a novel locking bug happening in there. I'm gonna write this up for the architecture team to look at but it'll probably end up status-wontfix. – Brian Nickel Apr 3 at 19:35

You must log in to answer this question.

Browse other questions tagged .